CSI Version Compatibility

This matrix shows the released versions of the Container Storage Interface (CSI) storage plugin and their compatibility with other components in a Kubernetes environment.

CSI Storage Plugin Version Compatibility
FUSE or Loopback NFS Kubernetes CSI Spec Core OS for Kubernetes Nodes OpenShift HPE Ezmeral Runtime Enterprise
1.0.x1 Loopback NFS 1.17 and later2 1.3.0 Release 6.1.0 and later3
  • RHEL
  • CentOS
  • Ubuntu
4.4, 4.5, 4.6, 4.72, 4.82, 4.9, 4.10 5.3.x, 5.4
1.2.x1 FUSE 1.17 and later2 1.3.0 Release 6.1.0 and later3
  • RHEL
  • CentOS
  • Ubuntu
4.4, 4.5, 4.6, 4.72, 4.82, 4.9, 4.10 5.3.x, 5.4
1.1.0 FUSE 1.16 and later 1.3.0 Release 6.1.0 and later3
  • RHEL
  • CentOS
  • Ubuntu
4.2 and 4.3 5.0 and 5.1
1.0.2 FUSE 1.13 and later 1.0.0 Release 6.1.0 and later3
  • RHEL
  • CentOS
  • Ubuntu
4.1 and 4.2 5.0 and 5.1
1.0.0 FUSE 1.13 and later 1.0.0 Release 6.1.0 and later3
  • RHEL
  • CentOS
  • Ubuntu
4.1 and 4.2 5.0 and 5.1

1Supports Raw Block Volumes.

2If your environment uses Kubernetes 1.20+ and OpenShift 4.7+, you must use FUSE 1.2.1+ and Loopback NFS 1.0.1+.

3In a release 7.0.0 environment, you must use Fuse 1.2.7+ and Loopback NFS 1.0.7+.