Troubleshooting the MapR Container for Developers

This section describes problems you may encounter when deploying, running, and accessing the MapR Container for Developers. It also includes steps to troubleshoot and resolve the problems.

Docker Login Problems

Problem
Attempting to log in to your Docker container returns the following error:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!    @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Possible Cause

You have an old ssh key in your .ssh/known_hosts file

Solution
Replace the old ssh key with the correct key:
ssh-keygen -R [localhost]:2222

Docker Failures

Problem

Docker fails to run the container

Possible Cause

Docker encounters problems starting Zookeeper or Warden

Solution
  1. Determine your Docker <container-id> by examining the output of the docker ps command
  2. Examine the Docker log files by running:
    docker logs <container-id>
  3. Examine the MapR log files specified in the output for further diagnostics. You need to log in to the container to see those files.
Problem
Docker completes its startup as shown by the following output from Docker logs:
This container IP : 172.17.0.2

But Docker is killed before MapR processes are running.

Possible Cause

You have not allocated enough memory to Docker

Solution
Make sure you have configured Docker with at least 6 GB of memory as described at Step 2c at Prerequisites to Running the MapR Container for Developers.

MapR Connection Problems

Problem

Unable to connect to MCS in your browser

Possible Cause Solution
The AdminApplication process is not running yet

Run jps and wait for AdminApplication to appear in the list of running java processes

You are accessing an older, cached copy of the MCS URL Clear your browser cache and retry connecting to the URL

Unable to Access MapR-DB Table

Problem
You cannot access a MapR-DB table
Possible Cause
You do not have permissions on the volume where the table is stored
Solution
When creating a volume, make sure you set up the user access controls appropriately. See Creating a Volume for details.

Unable to run OJAI Queries Due to Query Service Errors

Problem
When running an OJAI query, you encounter an error indicating that the Query Service is not enabled.
Possible Cause
The MapR Container for Developers is setup with only users mapr and root. You are running as some other user and your query requires the OJAI Distributed Query Service.
Solution
Add your user name and group to the container by following the instructions at Setting up New Users.