Java

To run data-fabric software and Hadoop, you must install a supported Java Development Kit (JDK) on your node.

Java

HPE Ezmeral Data Fabric requires the Java Development Kit (JDK). Installing only the Java runtime environment (JRE) is not sufficient. Verify that one of the following JDK versions is installed on the node:

Java Requirements for Data Fabric Core
  • Oracle Java JDK 11
  • OpenJDK 11
  • Amazon Corretto 11
NOTE: Make sure you have the development kit installed. Some JRE packages include jdk in the name, but do not provide the required JDK software.
Installation Information
To install one of the supported Java JDK distributions, see:
Special Requirements for Using OpenJDK

If you use OpenJDK:

  • RedHat/CentOS must have java-<version>-openjdk-devel installed.
  • SLES nodes must have java-<version>-openjdk-devel installed.
  • Ubuntu nodes must have openjdk-<version>-jdk installed.
NOTE: The openjdk-devel and openjdk-<version>-jdk packages include the jps command that lists running Java processes and can show whether the CLDB has started. This command is not supported in the Sun Java JRE.