Installer Updates

Installer updates provide new features or bug fixes.

The following table shows the Installer new-feature updates by version:
Version Updates
1.16.0.1.202108210519‑1 This version includes fixes for the following issues:
  • IN-2924: need to create symlink for mapr_fstab when using mapr-loopbacknfs
  • IN-2925: installer no longer correctly detects if zk are running
  • IN-2934: Ubuntu16 - mapr-setup.sh gpgkeys: protocol `https` not supported
  • IN-2935: Centos83 - fresh install failing with "mount.nfs: access denied by server while mounting localhost:/mapr"
  • IN-2947: extend cluster on ubuntu fails on nodes that do not have zookeeper installed
  • IN-2950: Bug in regex for mapr-setup.sh causes update command to fail
1.16.0.0.202105261033‑1 This version:
  • Adds support for MEP 7.1.0, SUSE 15 SP2, and the following ecosystem component version updates:
    • Hadoop 2.7.5
    • Object Store 2.1.0
    • HTTP-FS 1.1
    • Kafka 2.6.1
  • Includes fixes for the following issues:
    • IN-2821: DB services fail with error - Could not connect to the database: java.sql.SQLException: The server time zone value 'PDT' is unrecognized or represents
    • IN-2849: prereq check for services does not figure out that it needs to look for chronyd instead of ntpd for suse15
    • IN-2862: Couldn't install cluster by mapr user with sudo
    • IN-2879: FreshInstall - error while configuring mysql
    • IN-2883: mapr-installer-cli probe fails on Ubuntu-based MapR 6.2 cluster
    • IN-2892: mysql prereq check fails if no password is given - should only do so if not password was given on fresh install
    • IN-2893: make sure cron is installed - both OT and ES depend on it
    • IN-2895: permission errors reading pid files due to systemd changes
1.15.0.1.202103220200‑1 This version:
  • Adds support for HPE Ezmeral Data Fabric maintenance release 6.1.1, MEP 6.3.3, and SUSE 12 SP5.
  • Includes fixes for the following issues:
    • IN-2669: WebUI Node Configuration - usage of 'hostname -A' value
    • IN-2727: Support for SLES 12 SP4 and SP5 for Installer versions that support MapR 6.1
    • IN-2782: Tez UI not configured on security correctly via UI installer
    • IN-2784: Can't install cluster on CentOS 8.1 MEP-7.0.1
    • IN-2787: Check that sudoers file allow all commands for certain user if non-root user selected for installing
    • IN-2793: add check to network prereq check to make sure nodes have a domain portion in FQDN hostname
    • IN-2805: installer fails to parse mapr-patch file pattern for ubuntu files and 6.2.0 files
1.15.0.0.202101220818‑1 This version:
  • Adds support for installing the Object Store with S3-Compatible API. For installation considerations, see Installing the Object Store Using the Installer.
  • Installs Loopback NFS (mapr-loopbacknfs-<version>) on all nodes in the cluster unless Enable NFS is specified.
  • Adds support for Oracle Enterprise Linux 8.2 on release 6.2.0.
  • Includes fixes for the following issues:
    • IN-1289: Allow removal of installer node during verify
    • IN-2004: Install loopbacknfs by default if customer does not install NFS
    • IN-2232: We complain about firewall services being enabled on ubuntu
    • IN-2608: mapr-setup.sh installing with local repository - error on mapr-installer.service start
    • IN-2726: Installer should use HTTPS while connecting to https://package.mapr.hpe.com/
    • IN-2728: Mapr-installer failed installation with "Module did not set no_log for update_password"
    • IN-2735: Installer-master/ui1.14 - add mep506 632 701 support
    • IN-2742: Ansible execute shell script with no TTY
    • IN-2743: Certify Installer support for 6.2 on OEL (Oracle Enterprise Linux) 8.2
    • IN-2744: Implement simple UI for service verification feature in the Installer UI
    • IN-2754: Add loopbacknfs installation and configuration via MapR Installer
    • IN-2770: Installer needs to reflect minimum cluster requirement for 4 node clusters, rather than 5 node
    • IN-2778: need to change localhost login for root on shared mysql on ubuntu
    • IN-2785: Installer logs plenty of 'loglevel_int' exception messages
    • IN-2789: Centos 8 Installer with Use existing DB - database_existing.yml "No package MySQL-python available."
1.14.0.1.202010161154‑1 This version adds support for Red Hat / CentOS 8.2 and Oracle Enterprise Linux 7.8, as indicated in Installer Support Matrix. This version also includes fixes for the following issues:
  • IN-2680: mapr-setup.sh should provide option to setup Proxy preload
  • IN-2714: Support MapR core (no MEP) for Oracle Enterprise Linux 7.8 for MapR 6.1
  • IN-2715: Installer won't start on centos 8.2 when java 8 is installed
  • IN-2716: mapr-setup.sh - errors via Shell Script plugin validation
  • IN-2717: Installer Specification for versions supported and paths navigated on OS, java, and python environments
  • IN-2718: mapr-setaup.sh - ERROR: environment variable is set but do not contain http[s]: prefix - fix
  • IN-2719: proxy setting for mapr_core, mapr_installer.repo mep rep is incorrectly set to _none_always when installer on HPE network
  • IN-2720: install core 6.1.0 on centos 8
  • IN-2721: centos8 610_631 fresh install error on Stanza - Running task: Calling do_configure.sh from 'configure.yml' MODULE FAILURE
  • IN-2723: Please try an upgrade from core 6.1.0 to core 6.2.0 via installer on centos 8.x
  • IN-2724: Probe is broken in 1.14 - python3 and 4 digit issues
1.14.0.0.202009160311‑1 This version includes the following new functionality or characteristics:
  • Installer 1.14.0.0 supports MEP 7.0.0.
  • Installer 1.14.0.0 supports Red Hat / CentOS 8.1, Ubuntu 18.04, and Ubuntu 16.04, but does not support SUSE, as indicated in Operating System Support Matrix (Release 6.x).
  • Unlike Installer 1.13.0, Installer 1.14.0.0 runs on JDK 11.
  • The Installer can install Kafka Schema Registry 5.1.2.0.
1.13.0.0.201912130933‑1 This version includes the following new functionality or characteristics:
  • Installer 1.13.0.0 supports MEP 6.3.0.
  • Installer 1.13.0.0 supports Red Hat / CentOS 7.6 and 7.7 but does not support Ubuntu 18.04, as indicated in Operating System Support Matrix (Release 6.x).
  • Installer 1.13.0.0 supports HBase 1.13.0.
  • Unlike Installer 1.12.0, Installer 1.13.0.0 requires Java 8 and cannot run on Java 7.
1.12.0.0.201905241518‑1 This version includes the following new functionality or characteristics:
  • Installer 1.12.0.0 and later support the upload of a zipped tarball containing custom Ansible roles. These instructions can be executed in the installer workflow to customize the installation. For more information, see Using Custom Playbooks.
  • You cannot use Installer 1.12.0.0 or later to perform basic installer operations with 5.2.x releases. You must use Installer 1.11.0.0 instead. See Selecting an Installer Version to Use.
  • For data disks, Installer versions 1.12.0.0 and later require a minimum disk size that is equal to the physical memory on the node. If a data disk does not meet the minimum disk size requirement, a verification error is generated.
  • If you click a link in a Installer tooltip, the link is displayed in a new browser tab. Previously, clicking a tooltip link caused the browser to display the link in the same browser tab, and any changes made in the user interface were lost. This behavior has been corrected.
  • IN-2389 & INFO-1120: Sqoop2 cannot be installed using Installer 1.12.
  • IN-2417: Extending a secure cluster no longer fails with a mapruserticket error when you add a CONTROL node and DATA node at the same time.
1.11.0.0.201902141709‑1 No new features. This version includes the following fixes:
  • IN-2254: Ran out of memory on 1.10 installer - bump memory limits.
  • IN-2171: Unable to install Installer from packages on Suse.
  • IN-2155: Restrict expanding cluster groups based on service type not on group name.
  • IN-2154: Installer verification phase fails with error "ValueError: zero length field name in format."
  • IN-2123: Unable to extend secure cluster, mapruserticket not copied into new node.
  • IN-2108: Adding node with Extend Cluster fails at "get list of the ECO warden config files."
  • IN-2094: Installer verification fails for LUKS encrypted disks.
  • IN-2078: AttributeError in prereq check about OS.
  • IN-2025: Installer Error "Unscalable Host Groups" during 'extend cluster' or 'incremental install'.
1.11.0.0.201901301400‑1 This version includes the following new functionality or characteristics:
  • Support for MEP 6.1.0. For more information about MEP 6.1.0, see What's New in MEP 6.1.0.
  • The Installer provides a new advanced option that allows you to restrict the software to a subset of network interface cards (NICs) or to specify public IP addresses that can be used with the cluster nodes. See Using the MapR Subnet and MapR External Advanced Options.
  • The Installer warns you if you specify a host name using an IP address rather than a fully qualified domain name (FQDN). See Connectivity.
  • The Installer warns you if you run mapr-setup.sh -r <url> and specify a URL that is different from the URL currently stored in the properties.json file. See Troubleshooting Repository URL Errors.
  • The installer version (1.11.0.0) now uses four digits rather than three or two digits. For more information about 4-digit versions, see What's New in MEP 6.1.0.
1.10.0.201812181130‑1 No new features. This version includes the following fixes:
  • IN-2171: Unable to install Installer from packages on SUSE.
  • IN-2155: Restrict expanding cluster groups based on service type not on group name.
  • IN-2154: Installer verification phase fails with error "ValueError: zero length field name in format."
  • IN-2123: Unable to extend secure cluster, mapruserticket not copied into new node.
  • IN-2108: Adding node with Extend Cluster fails at "get list of the ECO warden config files."
  • IN-2094: Installer verification fails for LUKS encrypted disks.
  • IN-2078: AttributeError in prereq check about OS.
  • IN-2025: Installer Error "Unscalable Host Groups" during 'extend cluster' or 'incremental install.'
1.10.0.201809200839‑1 This version includes the following new functionality:
  • The installer provides a new option for setting Data-at-Rest Encryption (DARE). See Using the Enable DARE Option.
  • The installer provides a new option for setting the NSF version. See Installing NFS Using the Installer.
  • Changes have been made to the auto-provisioning templates. See Auto-Provisioning Templates.
  • With Installer 1.10, metrics collection is enabled by default on 6.1 or later and cannot be disabled. Metrics collection is required for metering. To support metrics collection, collectd is installed on all nodes in the cluster. Users can specify the full collection configuration for collectd or a minimum configuration to support only metering for billing purposes. If the minimum configuration is selected, HPE Ezmeral Data Fabric Database table metrics are disabled.
  • With Installer 1.10, the installer no longer includes an option to support off-cluster Elasticsearch and OpenTDSDB when security is turned on.
  • When installing Oozie 4.3.0, MapR Installer 1.10 leverages the Hadoop credential provider API to encrypt the Oozie database user password.
1.9.0.201803291415‑1 This version includes the following new functionality:
  • In the Installer, password verification is implemented for every password entered.
  • Changes have been made to the auto-provisioning templates. See Auto-Provisioning Templates.
  • The following services are renamed in Installer 1.9:
    Old Name New Name
    OJAI Query Service OJAI Distributed Query Service
    HBase/HPE Ezmeral Data Fabric Database Common MapR DataBase
1.8.0.201801312110‑1 This version includes support for 6.0, MEP 4.1.0, and the following new features:
1.7.201801021321‑1 No new features. This version includes the following fixes:
  • IN-1417: Cannot decode unicode character running Stanza
  • IN-1451: CFT_converged.yml when used with customized AMI errors out while creating stack.
  • IN-1445: URLs not accessible in AWS Marketplace offering.
  • IN-1422: Hue broken on fresh Install Azure and AWS Marketplace offers.
  • IN-1391: Use private hostname for Azure provisioning.
1.7.201711082221‑1 This version includes the following new features:
1.6.201708241301‑1 This version includes the following new features:
  • Support for Installing MapR in the cloud.
1.6.201708012220‑1 This version includes the following new features:
1.5.201704051050‑1
This version includes the following new features:
1.4.201612081140‑1
This version includes the following new features:
  • Support for MEP 2.0.
  • Support for Installer Stanzas.
  • Streams Tools.
Note these restrictions:
  • Installer 1.4 prevents you from downgrading a MEP.
  • Installer 1.4 shows only MEP versions equal to or greater than the version currently installed on your cluster.
This version includes the following updates:
  • 24891: Installer should not allow you to downgrade the MEP version.
  • 25213: Error in the process of upgrading Sentry by UI Installer 1.4.
  • 25277: v..swappiness should be set to "1" rather than "0" in RHEL/CentOS kernels > 2.6.32-303.
  • 23285: Installer leaves children behind after a stop.
  • 25421: mapr-setup fails to upgrade java.
1.3.201609291954‑1
This version includes the following updates:
  • 23258: The installer now creates a new log for each node for each iteration of the installer. Previously, the installer overwrote the original log file.

  • 23868: The installer now updates the livy_server_host property on Hue nodes and restarts the live server correctly.

1.3.201608121412‑1
This version includes the following new features:
  • When you install or upgrade to 5.2, you select a MEP version before you select ecosystem components.
  • When you install or upgrade to 5.2, you have the option to install Monitoring.
  • For local 5.2 installations, the -a parameter of mapr-setup.sh expects three archive files: Installer archive, Ecosystem Pack (MEP) archive, and the 5.2 archive.
This version includes the following updates:
  • 23853/22267: The installer validates advanced disk layouts such as /dev/mapper/luks-sdd or /dev/mapper/<lvm_logical_volume_name>.
  • 22904: The installer now allows you to update the cluster license during an incremental installation.
  • For local 5.0 and 5.1 installations, the archive filename has changed to mapr-5.0-5.1.<yyyymmdd>.*.tgz.
  • 24295: The installer detects disks correctly on Red Hat 7 operating system versions.
  • 24340: The installer no longer points to an old package manager (RPM) for the EPEL repository.
1.2.201606140935‑1 Version number change only.
1.2.201605032042‑1 This version includes the following updates:
  • 23137: On each node in the cluster, Installer automatically applies the latest patch available for the installed JDK version.
  • 22892: Installer no longer fails on Red Hat operating system versions that do not support systemd.
1.2.201602260909‑1 This version includes the following updates:
  • 21115: The installer performs a prerequisite check on the operating system version of Ubuntu and CentOS/Redhat nodes.
  • 21877: The mapr-setup.sh script provides the ability to specify a non-default hostname and port that nodes in the cluster can use to communucate with the MapR Installer node. You can set a non-default hostname or port using the new prompt that appears while mapr-setup.sh configures the Installer node or pass the script the -p <hostname:port> option when you run the command to execute the mapr-setup.sh script.
1.1.201601080826‑1 This version includes the following updates:
  • 21861: The installer sets the no_proxy environment variable for http connections to the Installer node.
  • 21440: On Safari and Internet Explorer web browsers, the Advanced Configuration settings for the service layout are now accessible.
1.1.201510241120‑1 This version includes the following updates:
  • 19850: The installer now configures the MySQL database to work with local connections.
  • 20115: The installer disables SELinux without requiring a reboot.
  • 19156: When you abort an installation, the installer provides a link to download the installation logs.
1.0.201508041436‑1 This version includes the following update:
  • If Java is not installed on RedHat/CentOS, mapr-setup.sh installs Open JDK Java 1.8.
1.0.201507171311‑1 This version includes the following updates:
  • 19541: The installer no longer supports SSL DHE cipher. It will also disable SSLv3.
  • 19465: When you use a custom service template, the installer now accurately displays service compatibility.
1.0.201507091731‑1 This version includes the following updates:
  • 18888: You no longer need to restart the mapr-installer process after you use the package manager to upgrade the installer package.
1.0.201506081725‑1 This version includes the following updates:
  • 18926: Installations no longer terminate due the restart of the sshd process.
  • Minor changes to text and layout on the Services page.
1.0.201506011415‑1 Version number change only.
1.0.201505261302‑1 This version includes the following fixes:
  • 18682: When you use package manager to update the installer definition file, you no longer need to re-run mapr-setup.sh.
  • 18748: The Installer no longer fails to install Hive 0.13 on Ubuntu when the repository includes Hive 1.0.