Operating System Support Matrix (Release 6.x)

This matrix shows the operating systems and versions supported by Release 6.2 and other 6.x releases.

For release 5.2.x information, see Operating System Support Matrix (MapR 5.x).

OS Version / Release Version Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
Red Hat Enterprise Linux (64-bit) 8.3 Yes Yes1, 4, 5, 7, 9 Yes1, 4, 5, 7, 9 No No
8.2 Yes No Yes1, 4, 5, 7, 9 No No
8.1 Yes No No No No
7.9 No Yes1 Yes1 Yes6 No
7.8 No No Yes1 Yes6 No
7.7 No No Yes1 No No
7.6 No No Yes No No
7.5 No No Yes Yes2 No
7.4 No No Yes Yes Yes
7.3 No No Yes Yes Yes
6.10 No No No No No
CentOS (64-bit) 8.310 Yes No Yes1, 4, 5, 7, 9 No No
8.210 Yes No Yes1, 4, 5, 7, 9 No No
8.110 Yes No No No No
7.910 No Yes1 No No No
7.810 No No Yes1 Yes6 No
7.710 No No Yes1 No No
7.610 No No Yes No No
7.510 No No Yes Yes2 No
7.410 No No Yes Yes Yes
7.310 No No Yes Yes Yes
6.1010 No No No No No
Ubuntu (64-bit) 18.04 Yes Yes Yes No No
16.048 Yes Yes Yes Yes Yes
14.04 No No Yes Yes Yes
SUSE (64-bit) 15 SP2 Yes11, 12 No No No No
12 SP5 No Yes No No No
12 SP3 No No Yes Yes2 No
12 SP2 No No Yes Yes Yes
Oracle Enterprise Linux3 8.2 Yes No No No No
7.8 No No Yes1 No No
7.4 No No Yes Yes Yes
7.3 No No Yes Yes Yes

1Requires a patch. See this support advisory. To install patches, see Applying a Patch.

2Use Installer 1.10 or later with this release. Before upgrading your operating system to Red Hat Enterprise Linux 7.5, CentOS 7.5, or SUSE12 SP3 or later, be sure to update the Installer to version 1.10 or later. See Updating the Installer.

3Release 6.x supports Oracle Enterprise Linux for core installations only. Ecosystem components are not supported.

4Supported only for MEPs 6.3.0 and later.

5NFSv4 is not supported for core 6.1.0 on Red Hat Enterprise Linux / CentOS 8.x.

6Requires a patch. Certified only for MEP 5.0.4. Other MEPs supported by release 6.0.x might work but have not been certified.

7Hue 4.3.0 in MEP 6.3.0 and 6.3.1 is not supported for Red Hat Enterprise Linux (RHEL) or CentOS 8.x. However, Hue 4.3.0.300 in MEP 6.3.2 can be used with RHEL or CentOS 8.x.

8RDMA is not supported with release 6.2 on Ubuntu 16.04.

9Installing release 6.1.0 on RHEL or CentOS 8.x requires you to enable the EPEL repository. Starting in RHEL 8.x, a mapr-core-internal package dependency (sdparm) is deprecated and moved to EPEL, and installation cannot complete without enabling it. For information about adding repositories, see Adding the Internet Repository on RHEL, CentOS, or Oracle Linux.

10See the HPE Ezmeral Data Fabric Advisory in response to CentOS 8 Discontinuance.

11NFS v4 is not supported for release 6.2.0 on SUSE 15 SP2.

12Requires a patch (core 6.2.0.7 or later). The https://package.mapr.hpe.com/ repository automatically provides the right patch version.