Selecting an Installer Version to Use

Beginning with the MEP 6.2 release, several Installer versions are available for use. The version that you use depends on your current core version and whether or not you need to upgrade using the Installer or Stanzas.

Choosing an Installer Version

In general, you should always use the latest available Installer version. The latest Installer version provides access to the latest Ecosystem Packs (MEPs). To download the latest version, see Downloading the Installer later on this page. For a list of recent Installer versions, see Installer Updates.

However, the latest Installer version does not support Release 5.x. You must use Installer 1.11.0.0 or 1.12.0.0 if your cluster is on a 5.x release. Installer 1.11.0.0 is the last version of the Installer to support installation for Release 5.x. Installer 1.12.0.0 is the last version of the installer to support upgrades from Release 5.2.x to Release 6.x.

If your cluster runs Release 5.2.x or a lower version of core, you must use Installer 1.11.0.0 to perform the following operations:
  • New installs
  • Incremental installs
  • Patch installs
  • Maintenance updates
  • Extend-cluster operations

This table describes how to select a Installer version based on your current software and your upgrade plans:

Core Version Use This Installer Version
5.1 Use Installer 1.11.0.0 for all operations, including upgrades to Release 5.2.x. Note that you must upgrade to 5.2.x with MEP 3.0.1 or later if you eventually want to upgrade to Release 6.x. After upgrading to 5.2.x, if you need to upgrade to Release 6.x, update the Installer to 1.12.0.0 before upgrading.
5.2.x Use Installer 1.11.0.0 until you need to upgrade to Release 6.x. To upgrade to Release 6.x using the Installer, your cluster must have Release 5.2.x with MEP 3.0.1 or later. Before upgrading, update the Installer to 1.12.0.0.
6.x and later Use the latest Installer version for all operations.

Downloading the Installer

This table summarizes download information for the Installer:
Installer Version Download Location The mapr-setup.sh script provided in this location installs . . . .
Latest Installer package.mapr.hpe.com/releases/installer/ The most current version of the Installer
Installer 1.12.0.0 package.mapr.hpe.com/releases/installer-v1.12.0 Installer 1.12.0.0
Installer 1.11.0.0 package.mapr.hpe.com/releases/installer-v1.11.0 Installer 1.11.0.0